Program to Print the Perfect squares between two intervals
Sample Input 1:
1 100
Sample Output 1 :
1 4 9 16 25 36 49 64 81 100
Program or Solution
# include <stdio.h>
# include <math.h>
int main()
{
int m, n,start,stop;
float p ;
printf("Enter two numbers : ") ;
scanf("%d %d", &start,&stop) ;
for(n=start;n<=stop;n++)
{
p = sqrt(n) ;
m = p ;
if (p == m)
printf("%d ", n) ;
}
return 0;
}
Program Explanation
refer video tutorialComments
Related Programs
- Program to print the Factors of a Number N
- Program to check whether given Integer is Prime or Not
- Program to print the Prime numbers between two intervals
- Program to print the Prime Factors of N
- Program to check whether given Integer is perfect number or not
- Program to print the perfect numbers between two intervals
- Program to check whether given Integer is Perfect Square or not
- Program to check whether given Integer is whether integer is power of 2 or not
- Program to find GCD of given numbers
- Program to find LCM of given numbers
coming Soon
coming Soon