Program to print the perfect numbers between two intervals
Sample Input 1 :
1 20000
Sample Output 1 :
6 28 496 8128
Program or Solution
#include<stdio.h>
int main()
{
int number, i,sum,start,stop;
printf("Enter two Numbers: ");
scanf("%d %d",&start,&stop);
printf("Perfect number between %d and %d:",start,stop);
for(number=start;number<=stop;number++)
{
sum=0;
for(i=1; i <= number/2; ++i)
{
if (number%i == 0)
{
sum+=i;
}
}
if(sum==number)
{
printf("%d ",number);
}
}
return 0;
}
Program Explanation
refer video tutorialComments
Related Programs
- Program to print the Factors of a Number N
- Program to check whether given Integer is Prime or Not
- Program to print the Prime numbers between two intervals
- Program to print the Prime Factors of N
- Program to check whether given Integer is perfect number or not
- Program to check whether given Integer is Perfect Square or not
- Program to Print the Perfect squares between two intervals
- Program to check whether given Integer is whether integer is power of 2 or not
- Program to find GCD of given numbers
- Program to find LCM of given numbers
coming Soon
coming Soon