Program to check whether given Integer is whether integer is power of 2 or not
Sample Input 1 :
64
Sample Output 1 :
64 is Power of 2 (2*2*2*2*2*2=64)
Flow Chart Design
Program or Solution
#include<stdio.h>
int main()
{
int number, n,i,flag=0;
printf("Enter a Number: ");
scanf("%d",&number);
n=number;
while(n>1)
{
if(n%2!=0)
{
flag=1;
break;
}
n=n/2;
}
if(flag==0)
{
printf("%d is a power of 2 ",number);
}
else
{
printf("%d is not power of 2 ",number);
}
return 0;
}
Program Explanation
refer video tutorialComments
Related Programs
- Program to print the Factors of a Number N
- Program to check whether given Integer is Prime or Not
- Program to print the Prime numbers between two intervals
- Program to print the Prime Factors of N
- Program to check whether given Integer is perfect number or not
- Program to print the perfect numbers between two intervals
- Program to check whether given Integer is Perfect Square or not
- Program to Print the Perfect squares between two intervals
- Program to find GCD of given numbers
- Program to find LCM of given numbers
coming Soon
coming Soon