3 digit number or not in python

Python Program to get a number num and check whether num is three digit number or not?.

Sample Input 1:

1000

Sample Output 1:

Not a three digit number

Sample Input 2:

987

Sample Output 2:

Three digit number

Flow Chart Design

3 digit number or not in python Flow Chart

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
num1=int(input("Enter your number:"))
if(num1 < 1000 and num1 > 99):
    print("{} is a 3 digit number ".format(num1))
else:
    print("{} is not a 3 digit number".format(num1))


			
				
			

Program Explanation

Get input num from user using input() method check whether the num is greater than 99 and less than 100 using if statement.

if it is true, then print num is three digit number using print() method.

Else print num is not three digit number using print() method.

Comments