Python if example

Python Program to get price and quantity of a product, calculate bill amount and calculate 10% discount for the bill amount 5000 and above.

Sample Input 1:

10 400

Sample Output 1:

4000

Sample Input 2:

10 500

Sample Output:

4500

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
noi=int(input("Enter the no of Items:"))
price=float(input("Enter the price:"))
amount=noi * price
if(amount>=5000):
    discount=amount*0.05
    amount=amount-discount
print("Bill Amount: {}".format(amount))


			
				
			

Program Explanation

Get two inputs quantity and price from user using input() method

Calculate amount by using the expression amount = quantity * price Check whether amount is greater than 5000 using if statement.

if amount is greater than 5000 then calculate discount and amount using the expressions discount = amount * 0.05 and amount = amount - discount.

print amount using print() method.

Comments