Last digit divisible by 3 or not in python

Python Program to get a number num and check whether last digit of num is divisible by three.

Sample Input 1:

27

Sample Output 1:

last digit not Divisible by 3

Sample Input 2:

43

Sample Output 2:

last digit divisible by 3

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
num=int(input("Enter a number:"))
last_digit=num%10
if(last_digit%3==0):
    print("{} is divisible by 3 ".format(last_digit))
else:
    print("{} is not divisible by 3".format(last_digit))


			
				
			

Program Explanation

Get input num from user using input() method extract last digit from num using the expression digit=num%10. check whether the remainder of digit divided by 3 is equal to 0 using if statement.

if it is 0, then print tdig is divisible by 3 using print() method.

Else print digit is not divisible by 3 using print() method.

Note: any number modulus of 10 gives last digit of number.

Comments