else if in python

Python Program to get price and quantity of a product, calculate bill amount, calculate 10% discount for the bill amount 5000 and above, 5% discount for the bill amount 1000 and above.

Sample Input 1:

10 400

Sample Output 1:

3800

Sample Input 2:

10 500

Sample Output 2:

4500

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
noi=int(input("Enter the no of Items:"))
price=float(input("Enter the price:"))
amount=noi * price
discount=0
if(amount>=5000 and amount<10000):
    discount=amount*0.05
elif(amount>=10000):
    discount=amount*0.1

amount=amount-discount

print("Bill Amount: {}".format(amount))


			
				
			

Program Explanation

chained conditional check is used here to check whether amount is greater than 5000 or greater than 10000. any one of the expression to calculate discount will be executed.

Comments