Smallest of two numbers in python

Python Program to get two numbers num1 and num2 and find the smallest one among num1 and num2.

Sample Input 1:

5 6

Sample Output 1:

5

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
num1=int(input("Enter your first number:"))
num2=int(input("Enter your second number: "))
if(num1<num2):
    print("{} is smallest".format(num1))
elif(num2<num1):
    print("{} is smallest".format(num2))
else:
    print("{} and {} are equal".format(num1,num2))
    

			
				
			

Program Explanation

Get two inputs num1 and num2 from user using input() statement check whether num1 is smaller than num2 using if statement.

if num1 is smaller print num1 using print() method, else check whether num2 is smaller than num1 using elseif statement.

If num2 is smaller print num2 using print() method, else print num1 and num2 are equal using print() statment.

Comments