Greatest of three numbers in Python

Python Program to get three numbers num1, num2 and num3 and find the greatest one among num1,num2 and num3.

Sample Input 1:

5 6 2

Sample Output 1:

6

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
num1,num2,num3=map(int,input("Enter three numbers:").split(" "))
if(num1>num2 and num1>num3):
    print("{} is greatest".format(num1))
elif (num2>num3):
    print("{} is greatest".format(num2))
else:
    print("{} is greatest".format(num3))

			
				
			

Program Explanation

Get three inputs num1, num2 and num3 from user using input() methods.

Check whether num1 is greater than num2 and num3 using if statement, if it is true print num1 is greatest using print() method.

Else, num2 or num3 is greatest.

So check whether num2 is greater than num3 using elseif statement.

if num2 is greater, then print num2 is greater using print() method.

Else, print num3 is greater using print() method.

Comments