Divisible by 3 or not in python

Python Program to get a number num and check whether num is divisible by 3.

Sample Input 1:

27

Sample Output 1:

Divisible by 3

Sample Input 2:

43

Sample Output 2:

Not divisible by 3

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
num1=int(input("Enter your number:"))
if(num1%3==0):
    print("{} is divisible by 3".format(num1))
else:
    print("{} is not divisible by 3".format(num1))


			
				
			

Program Explanation

Get input num from user using input() method check whether the remainder of num divided by 3 is equal to 0 using if statement.

if it is 0, then print num is divisible by 3 using print() method.

Else print num is not divisible by 3 using print() method.

Comments