check whether bit is set in python

Python Program to get a number n and bit I, check whether ith bit in num is set or not.

Sample Input 1:

8 3

Sample Output 1:

Not Set

Sample Input 2:

8 1

Sample Output 2:

Set Explanation: 0000 1000

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
num=int(input("Enter a number:"))
bit=int(input("Enter binary position:"))
num=num>>(bit-1)
if((num&1)!=0):
    print("{} is set".format(bit))
else:
    print("{} is reset".format(bit))
	

			
				
			

Program Explanation

left shift the number num by n-1 times move the nth bit to LSB.

Do AND operation between num and 1, if the LSB is 1 then output is 1, if LSB is 0 then output is 0.

Comments