C Program to Compare M divided by pow(2,n) and M>>N

Get number n and m, right shit the bits of n for m times:

Sample Input 1:

4 1

Sample Output 1:

2

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
#include<math.h>
int main()
{
	int num,n,output1,output2;
	printf("Enter a number and number of shifts:");
	scanf("%d %d",&num,&n);
	output1=num>>n;
	output2=num/pow(2,n);
	printf("%d %d",output1,output2);
	return 0;
}
			
				
			

Program Explanation

right shift is equal to divide a number by 2, right shift by n is equal to divide by pow(2,n)

Comments