C Program to convert bytes to kilobytes

Get bytes b from user and find kilobytes kb

Sample Input 1:

2048

Sample Output 1:

2

Sample Input 2:

1024

Sample Output 2:

1

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>

int main()

{

	int bytes;

	double kilobytes;

	printf("Enter number of bytes:");

	scanf("%d",&bytes);

	kilobytes=bytes/1024.00;

	printf("Kilobytes: %.2lf",kilobytes);

	return 0;


}
			
				
			

Program Explanation

Get bytes b as input (using scanf statement)

Calculate kilobytes kb by dividing bytes b by 1024.

(kb=b/1024, 1024 byts is equal to 1 kilobyte)

Print kilobytes kb (using printf statement)

Comments