C Program to calculate Fahrenheit to Celsius

Get Fahrenheit F from user and find celsius C

Sample Input 1:

92.2

Sample Output 1:

33.44

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>

int main()

{
    
	double f,c;
	printf("Enter fahrenheit:");
	scanf("%lf",&f);

	c=(f-32)*0.5556;  
	printf("Celsius: %.2lf",c);
    
	return 0;

}
			
				
			

Program Explanation

Get Fahrenheit f as input (using scanf statement)

Calculate Celsius c using Formula c=(f-32)*0.5556

print Celcius c (using printf statement).

Comments