C Program to convert kilobytes to bytes

Get kilobytes kb from user and find bytes b

Sample Input 1:

2

Sample Output 1:

2048

Sample Input 2:

1

Sample Output 2:

1024

Flow Chart Design

C Program to convert  kilobytes to bytes Flow Chart

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>

int main()

{

	int bytes;

	double kilobytes;
	printf("Enter Kilobytes:");

	scanf("%lf",&kilobytes);

	bytes=kilobytes*1024;

	printf("Bytes: %d",bytes);

	return 0;


}
			
				
			

Program Explanation

Get kilobytes kb as input (using scanf statement)

Calculate bytes b by multipllying kilobytes kb with 1024.

(b=kb*1024, 1024 byts is equal to 1 kilobyte)

Print bytes b (using printf statement)

Comments