C Program to convert Meters to Kilo Meters

Get meter m from user and find kilometer km

Sample Input 1:

56000

Sample Output 1:

56

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include <stdio.h>


int main(void) 
{
	
	unsigned int m;
	
	float km;

	printf("Enter Meters:");	
	scanf("%d",&m);
	
	km=m/1000.00;
	
	printf("Kilometers: %.1f",km);

	return 0;

}
			
				
			

Program Explanation

Get meter m as input (using scanf statement)

Calculate kilometer km by dividing meter m by 1000.

(km=m/1000, 1000 meter is equal to 1 kilometer) print kilometer km.

(using printf statement) (since kilometer may be in fractional values like 1.2 and 5.2, it is declared & print as float.)

Comments