C Program to print the last digit of given number N

Get an number n from user and display the last digit of n

Sample Input 1:

623

Sample Output 1:

3

Sample Input 2:

280

Sample Output 2:

0

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>

int main()

{
    
	int num,digit;
	printf("Enter a number:");
	scanf("%d",&num);

	digit=num%10;
	printf("Last digit: %d",digit);
    
	return 0;

}
			
				
			

Program Explanation

Get a number num (using scanf statement) Seprate the last digit of number num by "digit = num%10".

(% by 10 always gives last digit of a number) print the digit (using printf statement)

Comments