Java Program to calculate sum of N given numbers

Get input n and n inputs and calculate the sum of n inputs.


Example:

Sample Input 1:

4

6 5 3 2

Sample Output 1:

16

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

public class Hello { public static void main(String args[]) { //Write your code here } }

Program or Solution

				
			
					
import java.util.*;
class SumOfNInputs
  {
     public static void main(String args[])
     {
          int i,n,num,sum=0;
          System.out.println("Enter Number Of Numbers You Want To Sum");
          Scanner sc=new Scanner(System.in);
          n=sc.nextInt();
          System.out.println("Enter The Numbers To Sum");
          for(i=1;i<=n;i++)
          {
                num=sc.nextInt();
                sum=sum+num;
          }
         System.out.println("The Sum Is: "+sum);
     }
}
			
				
			

Program Explanation

1. Get input n (How many values to be added) 

2. Instruction(s) inside the for block{} are executed repeatedly till the second expression (j<=n) is true.

    for(i=1;i<=n;i++)

3. Here i is initialized to 1 and incremented by 1 for each iteration, instructions inside the for block are           

    executed      in every iteration. iteration stops when i becomes greater than n.

    num=sc.nextInt();

    sum=sum+num;

    so value of num given by user will be added to sum at each iteration.

    sum = sum + num

    sum = 0 + 5 (if 5 given)

    sum = 5 + 2 (if 2 given)

    sum = 7 + 9 (if 9 given)

    ...........

    ...........

after adding all n numbers given by user to sum, sum will be printed using system.out.println.

Comments