Java Program to print N Whole numbers

Get input n and print whole numbers till n.

Sample Input 1:

7

Sample Output 1:

The first Whole numbers are: 0 1 2 3 4 5 6 7

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

public class Hello { public static void main(String args[]) { //Write your code here } }

Program or Solution

				
			
					
import java.util.*;
class Whole
{
   public static void main(String args[])
   {
	int lim,i;
	System.out.println("Enter The Limit:");
	Scanner sc=new Scanner(System.in);
     	lim=sc.nextInt();
	System.out.println(" The First Whole Numbers are:");
	for(i=0;i<=lim;i++)
	{
		System.out.print(" "+i);
      	}
    }
}
			
				
			

Program Explanation

1. Get input limit (upto which number Whole numbers to be printed) 

2. Instruction(s) inside the for block{} are executed repeatedly till i less than or equal to limit. (i<=limit)

    for(i=0;i<=limit;i++)

3. Here i is initialized to 0 and incremented by 1 for each iteration, instructions inside the for block are executed      in every iteration. Iteration stop when i becomes greater than limit.


so value of i will be printed like   0 1 2 3 ....limit 


Comments