Java Program to print Multiplication table of N

Get input n and print the multiplication table of n

Sample Input 1:

4

Sample output 1:

1X4=4

2X4=8

3X4=12

4X4=16

5X4=20

6X4=24

7X4=28

8X4=32

9X4=36

10X4=40

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

public class Hello { public static void main(String args[]) { //Write your code here } }

Program or Solution

				
			
					
import java.util.*;
class MulTab
 {
     public static void main(String args[])
     {
          int i,table,numberoftimes;
          System.out.println("Enter The Number Of Times And Table value");
          Scanner sc=new Scanner(System.in);
          table=sc.nextInt();
          for(i=1;i<=10;i++)
            {
                 System.out.println(i+"x"+table+"="+i*table);
            }
      }
}
			
				
			

Program Explanation

1. Get table (For which number multiplication table should be printed)

    for(i=1;i<=10;i++)

2. Here i is initialized to 1 and incremented by 1 at every iteration, iteration stops when i is greater than 10.

System.out.println(i+"x"+table+"="+i*table);

3. prints the multiplication table of the table(number) from 1 to 10.


Comments