Java Program to print Hello World for N times

Get input n and print the text "Hello World" for n times

Sample Input 1:

3

Sample Output 1:

Hello World

Hello World

Hello World

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

public class Hello { public static void main(String args[]) { //Write your code here } }

Program or Solution

				
			
					
import java.util.*;
class Hello
{
   public static void main(String args[])
   {
	int lim,i;
        Scanner sc=new Scanner(System.in);
	System.out.println("Enter The Limit:");
	lim=sc.nextInt();
	for(i=1;i<=lim;i++)
	{ 
		System.out.println("Hello World ");
	}
  }
}

			
				
			

Program Explanation

1. Get limit from user (How many times "Hello World" Should be printed)

2. Instruction(s) inside the for block{} are executed repeatedly till the second expression (i<=lim) is true.

    for(i=1;i<=lim;i++)

3. Here i is initialized to 1 and incremented by 1 for each iteration, instructions inside the for block are executed      unless i becomes greater than lim.


so the string literal "Hello World" will be printed lim times.

Comments