Java Program to find whether the first digit of given number is odd or even

Get input num and check whether the first digit of number num is odd or even

Sample Input 1:

34

Sample Output 1:

The first digit is :Even

Sample Input 2:

67

Sample Output 2:

Even

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

public class Hello { public static void main(String args[]) { //Write your code here } }

Program or Solution

				
			
					
import java.util.*;
class Checker
{
  public static void main(String args[])
  {
        int num;
	Scanner sc=new Scanner(System.in);	
	System.out.println("Enter The Number:");
	num=sc.nextInt();
	while(num>=10)
	{
		num=num/10;
	}
	

	if(num%2==0)
	{
		System.out.println("The First Digit Is Even.");
	}
	else
	{
		System.out.println("The First Digit Is Odd.");
	}

  }

}
			
				
			

Program Explanation

1. Get num (to which first digit is to be identified)

2. Instruction(s) inside the while block{} are executed repeatedly till expression (num>=10) is true.

3. Divide the number num by 10 untill it becomes lesser than 10.

    once it is less than 10, check whether the number is even

    if even, print even. else print odd.

statement num = num/10 divides the num by 10 repeatedly until it num is less than 10


Example 

487

487/10 = 48

48 / 10 = 4

4 is less than 10, so check whether 4 is even.

4 is even, so print even.

Comments