Java Program to sum N Postive numbers, Skip Negative Numbers.

Get input n and n integers, then compute the sum of positive integers

Sample Input 1:

5

6 7 2 -8 1

Sample Output 1:

16

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

public class Hello { public static void main(String args[]) { //Write your code here } }

Program or Solution

				
			
					
//To Find The Sum Of Multiple Positive Number,Skips If user Enters Negative Numbers...

import java.util.*;

class Program
{
 public static void main(String args[])
  {
       int size,sum=0,i;
       Scanner sc=new Scanner(System.in);

       System.out.println("Enter The Size Of Array:");
       size=sc.nextInt();

        int a[]=new int[size];
       System.out.println("Enter The Array Elements:");

       for(i=0;i<size;i++)
        {  
            a[i]=sc.nextInt();
        }

      for(i=0;i<size;i++)
       {

            if(a[i]>0)
            {
                  sum=sum+a[i];
            }

        }

     System.out.println("The Sum Is:"+sum);

   }
}
			
				
			

Program Explanation

Comments