Java Program to find Exponentiation

Get two inputs num1 and num2, compute the exponentiation of base num1 and power num2 without using predefined functions

Sample Input 1:

2 4

Sample Output 1:

16

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

public class Hello { public static void main(String args[]) { //Write your code here } }

Program or Solution

				
			
					
//To Find N power of M (Exponentiation)...

import java.util.*;

class Program
{
 public static void main(String args[])
 {
 int base,pow,product=1;
 Scanner sc=new Scanner(System.in);

 System.out.println("Enter The Base:"); 
 base=sc.nextInt();

 System.out.println("Enter The Power:");
 pow=sc.nextInt();

 while(pow>0)
 {
 product=product*base;
 pow--;
 }

 System.out.println("The Output Is:"+product);
 }
}
			
				
			

Program Explanation

Comments