Java Program to calculate sum of ODD numbers till N

Get input n and calculate the sum of odd numbers till n

Sample Input 1:

5

Sample Output 1:

The Sum Of odd Number Till N:9(1+3+5)

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

public class Hello { public static void main(String args[]) { //Write your code here } }

Program or Solution

				
			
					
import java.util.*;
class SumOfNOdd
 {
    public static void main(String args[])
    {
       int i,j,N,sum=0;
       System.out.println("Enter The Value Of N");
       Scanner sc=new Scanner(System.in);
       N=sc.nextInt();
       System.out.println("The N Odd Numbers: ");
       for(i=1;i<=N;i+=2)
       {
            sum=sum+i;
       }
       System.out.println("The Sum Of N Odd Numbers: "+sum);
    }
}
			
				
			

Program Explanation

1. Get input N (To which odd numbers to be added)

2. Instruction(s) inside the for block{} are executed repeatedly till the second expression (j<=N) is true.

    for(i=1;i<N;i+=2)

3. Here i is initialized to 1 and incremented by 2 for each iteration, instructions inside the for block are executed      in every iteration. iteration stops when i becomes greater than n.

    so value of i (1,3,5,...n)will be added to sum.


    sum = sum + i 

    sum = 0 + 1

    sum = 1 + 3

    sum =  4 + 5

    ...................

after adding all  odd numbers till N to sum, sum will be printed using system.out.println.

Comments