Java Program to print N Natural numbers

Get input n and print natural numbers till n.

Sample Input 1:

7

Sample Output 1:

The First Natural numbers are: 1 2 3 4 5 6 7

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

public class Hello { public static void main(String args[]) { //Write your code here } }

Program or Solution

				
			
					
import java.util.*;
class Natural
{
   public static void main(String args[])
   {
	int limit,i;
	System.out.println("Enter The Limit:");
	Scanner sc=new Scanner(System.in);
     	limit=sc.nextInt();
	System.out.println(" The First Natural Numbers are:\n");
	for(i=1;i<=limit;i++)
	{
		System.out.print(" "+i);
      	}
    }
}
			
				
			

Program Explanation

1. Get input limit (upto which number natural numbers to be printed) 

2. Instruction(s) inside the for block{} are executed repeatedly till i less than or equal to limit. (i<=limit)

    for(i=1;i<=limit;i++)

3. Here i is initialized to 1 and incremented by 1 for each iteration, instructions inside the for block are executed      in every iteration. Iteration stops when i becomes greater than limit.


so value of i will be printed like   1 2 3 ....limit 

Comments