Python Right Shift Operator

Python program to get number n and m, right shit the bits of n for m times:

Sample Input 1:

4 1

Sample Output 1:

2

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
num1=int(input("Enter your First Number:"))
num2=int(input("Enter your Second Number:"))
num=num1>>num2
print("After Right shift: {}".format(num))

			
				
			

Program Explanation

right shift is equal to divide a number by 2, right shift by n is equal to divide by pow(2,n)

Comments