Simple interest in Python

Python program to get Principle amount, number of months, rate of interest from user and calculate

simple interest.

Sample Input 1:

5000 12 1.0

Sample Output 1:

600.00

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
p=float(input("Enter the Principal amount:"))
n=int(input("Enter the Number of Months:"))
r=float(input("Enter the rate of interest:"))
si=(p*n*r)/100
print("Simple Interest: {}".format(si))


			
				
			

Program Explanation

Get principal p, number of months n and rate of intereset r as inputs.

(using input() statement) calculate Simple Intereset SI by formula SI= p*n*r/100 print Simple Interest SI using print() method.

Comments