C Program to calculate sum of First N Natural numbers

Get input n and calculate the sum of first n natural numbers.

Sample Input 1:

5

Sample Output 1:

15(1+2+3+4+5)

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
	int n,i,sum=0;
	printf("Enter a number:");
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	{
		sum=sum+i;
	}
	printf("The sum of natural numbers till %d is : %d",n,sum);
	return 0;
}
			
				
			

Program Explanation

Instruction(s) inside the for block{} are executed repeatedly till the second expression (ifor block are executed unless i becomes greater than n.

so value of i (1,2,3,...n)will be added to sum.

after adding all n natural numbers to sum, sum will be printed using printf statement.

Comments


Related Programs