C Program to print N ODD numbers

Get input n and print n odd numbers.

Sample Input 1:

7

Sample Output 2:

1 3 5 7 9 11 13

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
	int n,i,j;
	printf("Enter a number:");
	scanf("%d",&n);
	printf("First %d odd numbers are:\n",n);
	for(j=1,i=1;j<=n;i=i+2,j++)
	{
		printf("%d ",i);
	}
	return 0;
}
			
				
			

Program Explanation

Instruction(s) inside the for block{} are executed repeatedly till the second expression (j<=n) is true.

Here i and j are initialized to 1 and i is incremented by 2 and j is incremented by 1.

for each iteration, instructions inside the for block are executed unless j becomes greater than n.

so value of i (1,3,5,7.....) (n odd numbers) in each iteration will be printed using printf statement.

Comments


Related Programs