C Program to print the first digit of a given number

Get input num and display the first digit of number num

Sample Input 1:

675

Sample Output 1:

6

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
	int n,num;
	scanf("%d",&num);
	n=num;
	while(num>=10)
	{
		num/=10;
	}
	printf("%d is the first digit in %d",num,n);
	return 0;
}
		
			
				
			

Program Explanation

Instruction(s) inside the while block{} are executed repeatedly till expression (num>=10) is true.

Divide the number num by 10 untill it becomes lesser than 10.

once it is less than 10 print the num using printf statement.

statement num = num/10 divides the num by 10 repeatedly untill it num is less than 10.

Comments


Related Programs