C Program to find N power of M (Exponentiation) without using predefined function

Get two inputs num1 and num2, compute the exponentiation of base num1 and power num2 without using predefined functions

Sample Input 1:

2 4

Sample Output 1:

16

Flow Chart Design

C Program to find N power of M (Exponentiation) without using predefined function Flow Chart

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
	int num1,num2,product=1;
	printf("Enter base and power value:");
	scanf("%d %d",&num1,&num2);
	while(num2>0)
	{
		product=product*num1;
		num2--;
	}
	printf("%d",product);
	return 0;
}
			
				
			

Program Explanation

4^5 = 4*4*4*4*4 multiply the 4 with product for 5 times using while statement.

Comments


Related Programs