C Program to calculate sum of ODD numbers till N

Get input n and calculate the sum of odd numbers till n

Sample Input 1:

5

Sample Output 1:

9(1+3+5)

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
	int n,i,sum=0;
	printf("Enter a number:");
	scanf("%d",&n);
	for(i=1;i<=n;i=i+2)
	{
		sum=sum+i;
	}
	printf("The sum of first %d odd numbers: %d",n,sum);
	return 0;
}
			
				
			

Program Explanation

Instruction(s) inside the for block{} are executed repeatedly till the second expression (i<=n) is true.

Here i is initialized to 1 and incremented by 2 for each iteration, instructions inside the for block are executed unless i becomes greater than n.

so value of i (1,3,5,...n)will be added to sum.

after adding all n odd numbers to sum, sum will be printed using printf statement.

Comments


Related Programs