C Program to print Multiplication table of N till M rows

Get input n and m, print the multiplication table of n till m

Sample Input 1:

4 7

Sample output 1:

1X4=4 2X4=8 3X4=12 4X4=16 5X4=20 6X4=24 7X4=28

Flow Chart Design

C Program to print Multiplication table of N till M rows Flow Chart

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
	int n,m,i;
	printf("Enter n and m value:");
	scanf("%d %d",&n,&m);
	for(i=1;i<=m;i++)
	{
		printf("%d X %d = %d\n",i,n,i*n);
	}
	return 0;
}
			
				
			

Program Explanation

Instruction(s) inside the for block{} are executed repeatedly till the second expression (i<=m)is true.

Here i is initialized to 1 and incremented by 1 for each iteration, instructions inside the for block are executed unless i becomes greater than m.

so value of i (1,2,3,...m)will be multiplied with n and printed in table format.

Comments


Related Programs