C Program to print Even numbers till N

Get input n and print even numbers till n.

Sample Input 1:

7

Sample Output 1:

2 4 6

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
	int n,i;
	printf("Enter a number:");
	scanf("%d",&n);
	printf("Even numbers till %d:\n",n);
	for(i=2;i<=n;i=i+2)
	{
		printf("%d ",i);
	}
	return 0;
}
			
				
			

Program Explanation

Instruction(s) inside the for block{} are executed repeatedly till the second expression (i<=n) is true.

Here i is initialized to 2 and incremented by 2 for each iteration, instructions inside the for block are executed unless i becomes greater than n.

so value of i will be printed like 2 4 6 .... (n-1) or n using printf statement.

Comments


Related Programs