C Program to find whether the first digit of given number is odd or even

Get input num and check whether the first digit of number num is odd or even

Sample Input 1:

34

Sample Output 1:

ODD

Sample Input 2:

67

Sample Output 2:

Even

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
	int num;
	printf("Enter a number:");
	scanf("%d",&num);
	while(num>=10)
	{
		num=num/10;
	}
	

	if(num%2==0)
	{
		printf("%d is even",num);
	}
	else
	{
		printf("%d is odd",num);
	}
	return 0;
}
			
				
			

Program Explanation

Instruction(s) inside the while block{} are executed repeatedly till expression (num>=10) is true.

Divide the number num by 10 untill it becomes lesser than 10.

once it is less than 10 check whether the num is odd or even.

statement num = num/10 divides the num by 10 repeatedly untill it num is less than 10.

Comments


Related Programs