C Program to calculate sum of N positive numbers(Skip the negative number and get another instated of that)

Get input n and n positive integers (skip the negative number), then compute the sum of positive integers

Sample Input 1:

5 6 7 2 -8 1 8

Sample Output 1:

24

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
	int n,i,num,sum=0;
	printf("Enter number of numbers to sum:");
	scanf("%d",&n);
	i=0;
	printf("Enter %d number to sum:",n);
	while(i<n)
	{
		scanf("%d",&num);
		if(num>=0)
		{
			sum=sum+num;
			i++;	
		}
	
	}
	printf("The sum is : %d",sum);
	return 0;
}
			
				
			

Program Explanation

user should give n positive integers, if user entered negative number continue statement skips the count and sum statements.

So this program gets n positive numbers and sum them.

Comments


Related Programs