C Program to print Whole numbers till N

Get input n and print whole numbers till n.

Sample Input 1:

7

Sample Output 1:

0 1 2 3 4 5 6 7

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#include<stdio.h> int main() { //write your code here }

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
	int n,i;
	printf("Enter a number:");
	scanf("%d",&n);
	printf("First %d Whole numbers are:\n",n);
	for(i=0;i<n;i++)
	{
		printf("%d ",i);
	}
	return 0;
}
			
				
			

Program Explanation

Instruction(s) inside the for block{} are executed repeatedly till the second expression (i<=n) is true.

Here i is initialized to 0 and incremented by 1 for each iteration, instructions inside the for block are executed unless i becomes greater than n.

so value of i will be printed like 0 1 2 3 .... n using printf statement.

Comments


Related Programs