Binary to Decimal in python

Python program to get binary number and convert it into decimal number.

Sample Input 1:

1010

Sample Output 1:

10

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
decimal_val,base=0,1
binary_val=int(input("Enter a Binary number"))
while (binary_val > 0):
    rem = binary_val % 10
    decimal_val = decimal_val + rem * base
    binary_val = binary_val // 10 
    base = base * 2
print(decimal_val)
    

			
				
			

Program Explanation

Yet to be updated

Comments