Print Natural numbers in pyhon

Python program to get input n and print natural numbers till n.

Sample Input 1:

7

Sample Output 1:

1 2 3 4 5 6 7

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
n=int(input("Enter n value:"))
for i in range(1,n+1):
    print(i,end=" ")
    

			
				
			

Program Explanation

For Statement is used to execute the sequence of instruction repeatedly.

Range() method gives list of elements, here range() method gives list which has 1,2,3... to n. for statement executes the instructions iteratively and for takes the elements one by one as value of i in sequential manner.

so it prints 1 to n.

Comments