sum of Even numbers in python

Python program to get input n and calculate the sum of even numbers till n

Sample Input 1:

5

Sample Output 1:

6(2+4)

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
n=int(input("Enter n value:"))
sum=0
for i in range(2,n+1,2):
    sum+=i
print(sum)
    

			
				
			

Program Explanation

For Statement is used to execute the sequence of instruction repeatedly.

Range() method gives list of elements, here range() method gives list which has 2,4,6... to n or n-1.

for statement executes the instructions iteratively and for takes the elements one by one as value of i in sequential manner.

so it adds even numbers.

Comments