Sum of natural numbers in python

Python program to get input n and calculate the sum of first n natural numbers.

Sample Input 1:

5

Sample Output 1:

15(1+2+3+4+5)

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
n=int(input("Enter n value:"))
sum=0
for i in range(1,n+1):
    sum+=i
print(sum)
    

			
				
			

Program Explanation

For Statement is used to execute the sequence of instruction repeatedly.

Range() method gives list of elements, here range() method gives list which has 1,2,3... to n. for statement executes the instructions iteratively and for takes the elements one by one as value of i in sequential manner.

so it adds i with sum1 in every iteration, finally produces sum of natural numbers.

Comments