First digit of number is odd or even in python

Python program to get input num and check whether the first digit of number num is odd or even

Sample Input 1:

34

Sample Output 1:

ODD

Sample Input 2:

67

Sample Output 2:

Even

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
n=int(input("Enter n value:"))
while(n>10):
    n=n//10
if(n%2==0):
    print("even")
else:
    print("odd")

    

			
				
			

Program Explanation

Given number is continously divided by 10, till it becomes lesser than 10 and greater than 0. and the final answer is first digit of given number.

If the first digit is divided by 2 then it is odd else it is Even.

Comments