Multiply without * operator in Python

Python program to get two inputs num1 and num2, compute the product of num1 and num2 without using * operator

Sample Input 1:

5 6

Sample Output 1:

30

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
num1=int(input("Enter first number:"))
num2=int(input("Enter Second number:"))
product=0
for i in range(0,num2):
    product+=num1
print(product)

    

			
				
			

Program Explanation

Insteaded multiply num1 and num2, just add num1 for num2 times.

For Example: num1 =4 and num2 = 3 4+4+4=12.

Comments