Print Natural numbers in reverse in python

Python program to get input n and print natural numbers from n in reverse.

Sample Input 1:

7

Sample Output 1:

7 6 5 4 3 2 1

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
n=int(input("Enter n value:"))
for i in range(n,0,-1):
    print(i,end=" ")
    

			
				
			

Program Explanation

For Statement is used to execute the sequence of instruction repeatedly.

Range() method gives list of elements, here range() method gives list which has n,n-1,.....,1. for statement executes the instructions iteratively and for takes the elements one by one as value of i in sequential manner.

so it prints n,n-1,.....,1.

Comments