Factorial in Python

Python program to find factorial of n

Sample Input 1:

5

Sample Output 1:

120

Flow Chart Design

Factorial in Python Flow Chart

Try your Solution

Strongly recommended to Solve it on your own, Don't directly go to the solution given below.

#write your code here

Program or Solution

				
			
					
n=int(input("Enter n value:"))
fact=1
for i in range(1,n+1):
   fact*=i
print(fact)
    

			
				
			

Program Explanation

For Statement is used to execute the sequence of instruction repeatedly.

Range() method gives list of elements, here range() method gives list which has 1,2,3... to n. for statement executes the instructions iteratively and for takes the elements one by one as value of i in sequential manner.

so it multiplies with fact in every iteration, finally produces product of n natural numbers.

Comments