Python Xor
Python program to Illustrate xor operator (A xor A ==> 0)
Sample Input 1:
6
Sample Output 1:
0
Sample Input 2:
28
Sample Output 2:
0
Program or Solution
num=int(input("enter the number:"))
num=num^num
print("num value is :{}".format(num));
Program Explanation
XOR any value with the same produces zero.Comments
Related Programs
- Python Addition
- Python Subtraction
- Python Multiplication
- Python Division
- Python Integer Division
- Python Modulus
- Python Exponentiation
- Kilometer to Meter in Python
- Meters to Kilo Meters in Python
- Area of Square in Python
- Area of Rectangle in Python
- Area of Right angled triangle in Python
- Area of triangle in Python
- Area of Circle in Python
- Circumference of Circle in Python
- Calculate Salary of Employee in Python
- Kilobytes to bytes in Python
- Bytes to kilobytes in Python
- Simple interest in Python
- Fahrenheit to Celsius in Python
- Celsius to Fahrenheit in Python
- Swap two numbers in Python
- Last Digit of integer in Python
- Set a bit in Python | Reset a bit in Python
- Python Left shift Operator
- Python Right Shift Operator
- Python Bitwise AND
- Python Bitwise OR
- Python Complement Operator
coming Soon
coming Soon