C Program to Swap two numbers using third variable
Get two integers a and b from user and swap the values
Sample Input 1:
6 5
Sample Output 1:
5 6
Program or Solution
#include<stdio.h>
int main()
{
int a,b,t;
printf("Enter a:");
scanf("%d",&a);
printf("Enter b:");
scanf("%d",&b);
t=a;
a=b;
b=t;
printf("\nAfter Swap\na:%d b:%d",a,b);
return 0;
}
Program Explanation
Get a and b using scanf statement swap the values using third variable t.
Print a and b using printf statement
Comments
Related Programs
- C Program to Addition of two numbers
- C Program to subtraction of two numbers
- C Program to multiply two numbers
- C Program to divide two numbers
- C Program to find modulus of two numbers
- C Program to convert Kilo Meters to Meters
- C Program to convert Meters to Kilo Meters
- C Program to find area of Square
- C Program to find area of Rectangle
- C Program to find area of Right angled triangle
- C Program to find area of triangle
- C Program to find area of Circle (Use Constant)
- C Program to find the distance between two points in 2D space
- C Program to calculate Salary of Employee
- C Program to convert kilobytes to bytes
- C Program to convert bytes to kilobytes
- C Program to find simple interest
- C Program to calculate Fahrenheit to Celsius
- C Program to calculate Celsius to Fahrenheit
- C Program to Swap of two numbers without using third variable
- C Program to print the last digit of given number N
- C Program to toggle a bit in number
- C Program to initialize a variable to zero using XOR Operator
- C Program to Compare M * pow(2,n) and M<<N
- C Program to Compare M divided by pow(2,n) and M>>N
coming Soon
coming Soon