C Program to toggle a bit in number

Get a number n and bit b, n is a number and b denotes any bit postion of n. set b postion of n as 1 if it is 0, reset b postion of n as 0 if it is 1.

Sample Input 1:

4 1

Sample Output 1:

5 Note: 4->0000 0100 After seting 1st Pos: 0000 0101 So output is 5.

Program or Solution

				
			
					
#include<stdio.h>
int main()
{
	int num,bit,n;
	printf("Enter a number and a bit:");
	scanf("%d %d",&num,&bit);
	n=1<<(bit-1);
	num=num^n
	printf("The value after %d bit is: %d",bit,num);
	return 0;
}
			
				
			

Program Explanation

Get a number num and bit as input (using scanf statement) left shift 1 by bit times (n=1<

Comments

kiruba
we want more clarification about the program. can you please insert some command lines inbetween the codes .
SanjaiR
Good Explanation and Easy to understand