C Program to convert Meters to Kilo Meters
Get meter m from user and find kilometer km
Sample Input 1:
56000
Sample Output 1:
56
Program or Solution
#include <stdio.h>
int main(void)
{
unsigned int m;
float km;
printf("Enter Meters:");
scanf("%d",&m);
km=m/1000.00;
printf("Kilometers: %.1f",km);
return 0;
}
Program Explanation
Get meter m as input (using scanf statement)
Calculate kilometer km by dividing meter m by 1000.
(km=m/1000, 1000 meter is equal to 1 kilometer) print kilometer km.
(using printf statement) (since kilometer may be in fractional values like 1.2 and 5.2, it is declared & print as float.)
Comments
Related Programs
- C Program to Addition of two numbers
- C Program to subtraction of two numbers
- C Program to multiply two numbers
- C Program to divide two numbers
- C Program to find modulus of two numbers
- C Program to convert Kilo Meters to Meters
- C Program to find area of Square
- C Program to find area of Rectangle
- C Program to find area of Right angled triangle
- C Program to find area of triangle
- C Program to find area of Circle (Use Constant)
- C Program to find the distance between two points in 2D space
- C Program to calculate Salary of Employee
- C Program to convert kilobytes to bytes
- C Program to convert bytes to kilobytes
- C Program to find simple interest
- C Program to calculate Fahrenheit to Celsius
- C Program to calculate Celsius to Fahrenheit
- C Program to Swap two numbers using third variable
- C Program to Swap of two numbers without using third variable
- C Program to print the last digit of given number N
- C Program to toggle a bit in number
- C Program to initialize a variable to zero using XOR Operator
- C Program to Compare M * pow(2,n) and M<<N
- C Program to Compare M divided by pow(2,n) and M>>N
coming Soon
coming Soon